NW Business Intelligence

thoughts on technology, B.I., and more…

Posts Tagged ‘Report Builder 3.0’

SSRS Report Builder 3.0 and IE9 needs .NET 3.5

Posted by Brad Greene on June 12, 2011

If you are using Microsoft IE 9 browser and the new Report Builder with SQL Server 2008 or later you may have run into the error below when trying to start RB 3.0. It seems odd at first because Windows 7 comes with .NET 3.5. I learned after a little searching that the issue lies with IE9. The problem is easily resolved by setting the Compatibility mode for this URL (the one you use to access your SSRS Report Server). You may have to enable the setting in IE9 under the Tools menu. Do a web search for how to enable Compatibility on IE9 and you will find an MS Support site article showing you how to do it. With that turned on the browser behaves like prior releases and, I assume, allows it to find the .NET Framework that RB 3.0 requires to run.

Report Manager error opening Report Builder 3.0

Report Manager error opening Report Builder 3.0

With the Compatibility mode set to “on” as indicated by the icon below Report Builder now runs as expected.

Report Manager opening Report Builder 3.0

Report Manager opening Report Builder 3.0

Posted in Business Intelligence, Tech Tips | Tagged: , , | 1 Comment »